Subject: Re: Recompilation of last1120c

From: [email-masked]
Date: Mon, 10 Jan 2000 01:52:24 -0500

I fiddled the primevalC page; let me know if it works and if
other information would be useful.

	Dennis

Subject: Re: Recompilation of last1120c
From: Warren Toomey <[email-masked]>
To: [email-masked]
Cc: [email-masked] (Warren Toomey)
Date: Mon, 10 Jan 2000 16:26:02 +1100 (EST)

In article by [email-masked]:
> Warren wrote:
> 	Just a quick note. Using s2-bits C compiler, I have recompiled
> both c0 and c1 from last1120c. Then by moving the new c0 and c1 into
> /usr/lib, I have recompiled c0 and c1 with themselves.
>
> Excellent!
> 	Dennis

The latest emulator is at ftp://minnie.cs.adfa.edu.au/pub/PDP-11/Sims/Apout/
and I've also included there the last1120c course and the binaries required
to recompile it. Could you change your primeval.html page to point here?

I think it will be nigh impossible to recompile prestruct-c, because of
all the missing table files in assembly. I've tried to substitute the
existing last1120c files for those missing in prestruct-c, but I get
serious parse error when I run the resulting c0 binary.

I've only got the last1120c and prestruct-c source directly from your web
page: these files have lost their timestamps. Could you send me the original
tap/tp archives, just for historical accuracy?

Well, I've run out of things to do for a bit, until copies of the 2nd Ed
manuals arrive from Norman. My emulator currently supports binaries from
V1, V2, V5, V6, V7, 2.9BSD and 2.11BSD. I won't bother to emulate V3/V4
because there are no binaries to run :-)

Cheers,
	Warren

---

From: [email-masked]
Date: Mon, 10 Jan 2000 02:06:56 -0500

Oh! I forgot to mention that the last* and pres* bits
are in the ftp incoming directory, same place as
s1 and s2 were (what is it, plan9.bell-labs.com/incoming/dmr ?)

	D.

---

From: [email-masked]
Date: Mon, 10 Jan 2000 02:15:27 -0500

Reload or something....

p9C; ls -tl
--rw-rw-r-- M 815 dmr web 295936 Jan 10 00:34 last1120c-bits
--rw-rw-r-- M 815 dmr web 295936 Jan 10 00:34 prestructc-bits
--rw-r--r-- M 815 dmr web 295936 Jan  4 02:54 s2-bits
--rw-r--r-- M 815 dmr web 295936 Jan  4 02:54 s1-bits

Subject: Re: Recompilation of last1120c
From: Warren Toomey <[email-masked]>
To: [email-masked]
Date: Mon, 10 Jan 2000 18:13:15 +1100 (EST)

> s1 and s2 were (what is it, plan9.bell-labs.com/incoming/dmr ?)

At present:

ftp> dir
200 Data port is tcp!131.236.2.210!56575
150 Opened data connection (tcp!131.236.2.210!56575)
total 1156
-rw-r--r--   1 none     none      295936 Jan  4 01:17 s1-bits
-rw-r--r--   1 none     none      295936 Jan  4 01:17 s2-bits
226 Transfer complete

So perhaps later, there's no rush.

Cheers,
	Warren