Subject: Re: What code USL -> Novell?

From: Dennis Ritchie <[email-masked]>
Date: Tue, 9 Sep 2003 23:42:11 -0400

Hi Warren, I trust you haven't been hassled much by
(current) SCO.  At least the archive seems to
mentioned  only in passing by other parties
and not a subject of the suit itself.

> When Novell bought USL, do you know exactly what source code trees they
> were given, or which trees USL were in possession of?

No, I don't know, nor do I know (off the top of the head)
what was the current version of SV at the time of the
sale--presumably r4.

 I may have told you this story before, but at the time
of USL's final spinoff from AT&T, I had the documents
about what USL got from AT&T Computer Systems.  By way of OS,
it really talked only about System V.  During the BSDI suit,
I thought that possibly the whole thing could be short-circuited
by AT&T releasing 5e through 32V.  The Bell Labs (AT&T) lawyer I talked
to observed that on the surface only SV was part of of the
deal, and the argument could well be made, but there was a
reference in the contract to "development versions" and this could
be used to argue that everything (from the start) was part of this.
(There was certainly no language that kept ownership of
early versions with AT&T).

I didn't try to push the matter further--
AT&T itself had  divested USL it it seemed highly unlikely that
I could get support for interfering in someone else's ongoing
suit.

 > In a newspaper article I mentioned that I had to ship the Santa Cruz
 > Organization copies of 5e, 6e, 7e, 32V and SysIII because they did not
 > have these old versions.

As for the Novell-SCO sale, and what SCO got (whether mentioned
in the contract, or what materials they got), I have no information. 
As you say, SCO during its kindlier phase didn't seem to have
physical copies of the earlier code, which you and they got from
people who had tapes or their own archives.

My take on this is that current SCO is indeed the owner
of the SV code and its direct predecessors--the predecessors
because (at the time) no one contested this.  Clearly much
of this leaked out, though through the 80s and 90s it
was subject to licenses, as were (I suppose) AUSAM sources, Ultrix,
the early BSDs.

In the earlier case the judge didn't seem to be too much impressed
by USL copyright claims (partly for reasons having to do with
then-current US law), or the trade secret ones (approximately,
too many people know the secret).

 > I'd like to try and definitely determine if current SCO have a break
 > in their code genealogy, e.g they are missing SysV or SysVR1 or SysVR2.
 > It would lend weight to the argument that some of the code that they
 > claim leaked into Linux might actually be code that was inherited from
 > (say) AUSAM, Ultrix or the early BSDs.

A break in chain-of-custody looks more than probable; whether
this is a useful argument is another question.

Best wishes with the course.  You might be interested in hearing
that one of the MIT introductory courses in OSs is trying to
use Lions as source material (complete with a simulator)--
but sadly the republished book is out of print.  So they're
using Xeroxes again!

	Dennis

---

From: Dennis Ritchie <[email-masked]>
Date: Thu, 11 Sep 2003 02:27:22 -0400

> Are there any publicly available records on the USL divestiture from
 > AT&T, that list what you have described, i.e SysV and development
 > predecessors?

I can't imagine that the whole agreement would be available
from public records (except of course that the fact itself
would be somehow recorded) but not the IP contract.
Somewhere I think I might still have this, but the only thing
I was able to dig up was the one page.  The rest
did cover some non-OS software.   As I recall, C++
rights (to whatever compiler was extant then) were
included, but in a later agreement went back to AT&T.
I'll keep looking.

 > Yes, I don't know if it is useful, but I thought I should at least
 > try to follow it up in case SCO wheels out lots of 4.2BSD code and
 > says "We wrote this".

In the case of 4.2BSD code, although SCO didn't write it,
it's likely they could readily that they do seem to have grandfathered
rights, given that it was covered under UCB's agreement
with AT&T/WECo.  On the other hand, the rights do seem
to be diluted considerably given the terms of the the
licenses granted by the earlier SCO.  I asked whether you (TUHS)
were being hassled because if the early stuff was really
important, one would expect that they would take action.

 > Now that's ironic, the many-times photocopied book goes underground again.
 > Yes I had some e-mail from MIT last week with a patch to my PDP-11 Apout
 > simulator: they are using it to quickly compile the 6e kernels.

Well, not really underground, just the publisher not keeping it
current.

 > One last thing, I've been asked again what you are doing with the paper-only
 > documents from 2nd Edition and earlier (code snippets etc.) Were they every
 > scanned in, or are they still in paper-only format?

Still paper-only, I'm afraid, but there's not a lot there.

	Regards,
	Dennis