Subject: PDP-7 UNIX listings

From: Warren Toomey <[email-masked]>
Date: Fri, 14 Aug 2009 10:55:39 +1000

Hi Dennis, how's things? I hope you are recovered from your injury, including
getting back to your normal level of endurance. Usenix winter conference
went well, there was a sharp drop in numbers, but as it was my first
Usenix conference I still enjoyed it, and the old Unix restoration paper
was much appreciated.

I had the following e-mail from Ian King, who is a PDP-7 afficionado. He
asked me to forward the request on to you: if possible could he/we get
copies of the remaining PDP-7 listing fragments?

I explained that a full PDP-7 UNIX does not exist, but he would still be
very happy to have the extant listing displayed next to the PDP-7.

Many thanks in advance for any help!

Cheers,
	Warren

----- Forwarded message from Ian King <[email-masked]> -----

From: Ian King <[email-masked]>
To: "[email-masked]'" <[email-masked]>
Subject: The original UNIX?

Warren,

Hello!  I hope this email finds you well.

One of my colleagues, Rich Alderson, has been attempting to contact Dennis Ritchie about the status of the original assembly language version of UNIX, without success.  As you may know, we are restoring the PDP-7 that used to belong to the University of Oregon's high energy physics lab (serial number 113).  We would love to be able to run that original code.  It's our understanding it is not available electronically, but we would not be daunted by the task of reconstructing it from printed listings.  When Rich told me he has not heard from Dr. Ritchie, your name came to my mind as someone who would be 'in the know'.  :)

We would be very grateful for whatever help or guidance you can provide.  Thanks - Ian

UNIX is user friendly.  It's just selective about who its friends are.
Ian S. King, Sr. Vintage Systems Engineer
Vulcan, Inc.
http://www.pdpplanet.com
----- End forwarded message -----

---

From: [email-masked]
Date: Sat, 15 Aug 2009 23:13:59 -0400

Well, I'm not completely back, but getting around.
I saw the slides, also the video.  It did indeed seem to go well,
congratulations.

I will keep an eye out for PDP-7 stuff.  While I was away
the house was completely redone, which it needed, but
it's as if I moved, which I rather was, just in the same rooms.
But I'm still unpacking!

   Regards,
   Dennis

---

From: [email-masked]
Date: Tue, 20 Oct 2009 21:07:21 -0400

I looked at the first AAUG things-- they are interesting.
I've just had some correspondence with one of the
lexicographers from OED who was interested particularly
in when "root" was first used as an actual user name
as opposed as the name of the root directory.  Turns
out to be hard to document.  (Best we've been able to
find is in the v5 password file that I have and is in the
TUHS archive) but he'd prefer a published reference.
There is one in paper by Stonebraker from I think 1975.

In other news, I have found the book that has the listings
that I knew I had, that of (some) of the user-level commands.
I wonder what's the best way to get it scanned?

I sent mail to Lorinda telling her that you're a good guy.
I'm not sure what she has, but we'll see.

  Dennis

---

From: Warren Toomey <[email-masked]>
Date: Tue, 20 Oct 2009 16:03:19 +1000

> it's as if I moved, which I rather was, just in the same rooms.

Hope the unpacking went well. I've been busy scanning in old AUUG newsletters
at this end, and I hope to get all the issues scanned in by year's end:

	http://minnie.tuhs.org/AUUGN/

Feel free to snag a copy, or I can post you a CD if you want.

P.S At USENIX, Bill Cheswick & Andrew Hume told me that Lorinda Cherry
had a pile of UNIX memorabilia in her office. I got Lorinda's e-mail from
Andrew, but after contacting her I haven't received a reply. I'm worried
that I might have rubbed her the wrong way. Not sure if you can recommend
me to her, or at least summarise the history work I've done in the past.

Cheers,
	Warren

---

From: Warren Toomey <[email-masked]>
Date: Wed, 21 Oct 2009 11:21:37 +1000

> There is one in paper by Stonebraker from I think 1975.

On your s2-bits DECtape, /etc/passwd contains:

root::0:/:
eroot::0:/:/bin/ed
sys::1:/usr/sys:
bin::3:/bin:
adm::3:/usr/adm:
s1::3:/usr/s1:
s2::3:/usr/s2:
jack::10:/usr/jack:
peter::11:/usr/peter:
jay::12:/usr/jay:
bob::13:/usr/bob:
sun::14:/usr/sun:
lee::15:/usr/lee:

and the timestamp is

-rw--  1   221  239 Feb  6 14:35 /etc/passwd            2081934621 

but see
http://minnie.tuhs.org/Archive/PDP-11/Distributions/research/1972_stuff/Readme
for discussion on the epoch.

> I wonder what's the best way to get it scanned?

If you can photocopy individual pages, I can scan them in and OCR them.
 
> I'm not sure what she has, but we'll see.

Thanks Dennis!
	Warren

---

From: [email-masked]
Date: Wed, 26 Jan 2011 18:38:25 -0500

Thanks much,  I'm still coming to terms--
even though I was told in December,

  Regards,
  Dennis

---

From: Warren Toomey <[email-masked]>
Date: Thu, 27 Jan 2011 08:49:27 +1000

Dennis, just read about your/Ken's Japan prize. Congratulations!
Hope you & family had a good Xmas, and best wishes for
health & happiness in 2011.

Cheers,
	Warren