Subject: Re: your mail

From: [email-masked]
Date: Wed, 4 Apr 2001 23:45:19 -0400

Here's what I last sent to Greg.  The putting-in and and subsequent
removal of the copyright notices happened well before 32V,
although 32V, as the primary source for BSD was presumably
most important in the lawsuit.

Saw your note to the usenix group asking to see any early
licenses.  As I said, I am quite sure that the licenses themselves
are not sensitive in any way, but I can understand that you want
to be careful with your materials.

	D.

 ----
From: dmr
Date: Wed Apr  4 22:36:43 EDT 2001
To: [email-masked] dmr
Subject: Re: ancient Unix question 

The only USL-BSDI lawsuit material I have came from BSDI's site as well.  If you're
in contact with Kirk, he's a better source.

On the Memo for Record:  1984 was
when AT&T was just leaping into the commercialization,
and so they were presumably thinking more carefully
about the IP issues, and maybe there were changes in law or
regs.  The earlier advice about whether to incorporate copyright
notices mentioned by Johnson occurred well before this.

Incidentally, I spent a lot of time with the USL folks
before the suit trying to work out some sort of
compromise, though to no avail.  At least I
managed to keep the trust of both sides.

Steve Johnson's story about the copyright notices is in accordance
with my memory, although I don't remember the LOC
specifically.  There was a brief period when the lawyers
decided that copyright and trade secret were incompatible,
and they'd rather go with the latter.  Whether or not
this was true or they were mistaken in their belief as of
then-current law, I know not.

This  probably happened between the 4th and 5th
edition.  One of the reasons for doing the 5th so
close to the 4th was that the 4th (I think) had the notices;
the 5th was done partly to take them out.  We
wrote to the holders of the 4th and offered a
free upgrade to people who would send back
the older tape.

[The first draft of this paragraph said "5th and 6th"
editions.  In checking the dates, 4th and 5th is much
more likely to be accurate:  4th was Nov 1973, 5th was
June, 1974.  6th was May, 1975.    We don't have
the sources for the 4th ed, so I can't verify the
existence of included copyright notices in its code.
We do have the 5th and 6th sources, and they definitely
lack them.  This is to some extent a reconstruction,
but there was definitely a flip-flop in advice, as Johnson
remembers.]

[Another side note: although I don't have text of the
licenses to prove it, there was a definite change between
the 6th and 7th licenses about University teaching.
John Lions wrote his "Commentary" book about the 6th
and this was regarded with mixed reaction from the
growing business group.  More about this if you need it.]

About  C manual: yes.  K&R 1 and the 7th edition were
more or less the same time, and Brian and I wanted
to sell more books.  I don't think we even consulted
with Prentice-Hall, we just decided not to distribute
what amounted to a chunk of the book.

The wumpus game was indeed from PCC, I believe,
though there were other versions.  I think we did
have a subscription, or maybe just Ken did.  He wrote the C
(maybe even B) translation for his son, who was
just at the right age at the time.

You'll have to wheedle Toomey about seeing the early licenses
themselves.  I didn't save them, and at some point a bit
ago I tried to find an appropriate archive in the company,
but this bit of history seems to have been lost locally.

---

From: [email-masked]
Date: Tue, 24 Feb 2004 22:37:23 -0500

First, about the reconstructed facts: When I wrote
 > > but there was definitely a flip-flop in advice, as Johnson

I should have stuck with the first draft.
I don't know about the 4th edition system or
even remember whether it was collected or distributed at all,
but I must have looked in the wrong places in 5th and 6th.
You are right; 5e has notices almost everywhere, 6e doesn't.
I must have been fooled somehow by the dates, or perhaps
(I'm guessing here) there was a tentative 6th that was withdrawn--
something on the order of "we have an updated version."

> Looking through the 5e and 6e distributions that you sent me,
> there are dozens of copyright notices in 5e but none in 6e; it therefore
> seems that the removal occurred between 5e and 6e, not 4e and 5e.
> 
> You mentioned that "We wrote to the holders of the 4th and offered
> a free upgrade to people who would send back the older tape." I don't
> suppose a copy of the letter would still exist?

I'm pretty sure the letter doesn't exist; at any rate I don't
have it.  In dredging up ancient memory, I think only
a couple of licensees were involved.

> Is there a way for me to describe the insertion/removal of notices
> which would be acceptable to you? Possible options are:
> 	- I name & quote you
> 	- I refer to a Bell Labs employee and quote you
> 	- I refer to a Bell Labs employee and paraphrase you
> 	- I wave my arms around and indicate that I was told this
> 	  in a private correspondance from a reliable source
> 
> If you have any ideas or suggestions on how I might proceed, that would
> be good. Remember that I am being retained by IBM, so I might be asked
> to name names at some stage.

Well, you have some ground facts (the 5e and 6e distributions)
in which notices are there in the earlier and not the later.
(Nor, of course, in 7e or 32V, as came up in the BSDi case).

It's certainly true that at some time we were asked to add notices,
and later to remove them, as Johnson also said.  Right now
the best evidence is that this occurred between 5e and 6e.
You can certainly say that I remember our being asked
to add notices, and later to remove them.

	Dennis

---

From: Warren Toomey <[email-masked]>
Date: Wed, 25 Feb 2004 11:51:51 +1000

Hi Dennis, how's things?
	Back in 2001 you e-mailed the information below to me. I'm writing
an article for Groklaw about the history of copyright notices on the
Unix releases from 3rd Edition onwards. The details about notices
being inserted and then removed is very relevant, but all I have
is the private e-mail from you below.

Many thanks again,
	Warren