Subject: Re: A Question on Idris

From: [email-masked]
Date: Tue, 3 Feb 2004 20:29:25 -0500

> 	I'm doing some work for IBM on the you-know-what case, and I have
> a few questions for you. However, I don't know if you're allowed to give
> opinions on things, so let me know if I am out of order here.

I've avoided opinion about things except where I have
documented facts.  I'm allowed to talk, but I'm cautious
about  being silly in public.  SCO has broadcast lots of silly things
but I won't.

> I recall an e-mail from you where you said that you went to visit
> Whitesmiths after they released either Idris or their C compiler,
> to verify that no UNIX code was in the product. However, I can't
> find the e-mail, and it was a good story too.

This is a misremberance: the company I  looked at was
Mark Williams, and their Coherent product.
I found a version of my account on google groups:

  http://groups.google.com/groups?q=ritchie+coherent+williams&hl=en&lr=&ie=UTF-8&safe=off&selm=tgmErpF97.JCC%40netcom.com&rnum=1

and I found this by looking for "ritchie coherent williams"
in advanced group search.

> I know that Whitesmith made their products deliberately incompatible
> with Unix to begin with: function names, constant values etc. Later,
> they made things compatible. Did AT&T give their official "blessing"
> to such compatible products?

Whitesmith's Idris (main person Bill (P. J.) Plauger) was I think a bit earlier
than Coherent.  I don't know whether he asked or received official blessing.
At the time, my reaction was that he was being excessively cautious to make
many of the changes he did, but no doubt he was also motivated
by a desire to rethink and redesign some of the primitives and interfaces.

> I'm assuming that Idris would have released quite a number of header
> files which were similar to, if not nearly identical to, UNIX header
> files (errno.h, signal.h, ctype.h in particular). The earliest
> evidence I have for this dates back to 1978. Did this cause any concern
> within AT&T? Was there a policy or a consensus within AT&T that other
> companies could copy the contents of these files?

All the signs are that the system interfaces (behavior of
commands, structures involved in system calls) as shown in the manuals
and in published papers were reasonably public, and AT&T
didn't chase people because of them. I don't
recall Whitesmith/Idris being looked at suspiciously,
but you could ask him whether he was hassled.

Coherent was looked at but not pursued.  BSDi was a special case;  USL
convinced themselves that BSDi (and CSRG) could not possibly
have done what they did without wholesale code importation.
In some ways I think USL had a moral case in that without
10 years or so of experience with licensed Unix, UCB couldn't
really have done what they did, but when it came down to
the facts about common code, plus published material like
SVID and Bach's book, plus the details concerning copyright,
they didn't prevail.

> Thanks again, hope you & family had a good Xmas & New Years too!

Had a nice trip to England to visit my sister, with a boxing
day journey to Scotland.  Best to you as well.

	Dennis

---

From: Warren Toomey <[email-masked]>
Date: Wed, 4 Feb 2004 10:14:27 +1000

Hi Dennis,

	Warren