Subject: Re: Some Success with s1-bits archive

From: [email-masked]
Date: Sat, 8 Jan 2000 04:03:23 -0500

> I've made a start on running the 2nd Ed binaries on s2-bits by assuming that
 > the system API was the same as 1st Edition. At present, size(1) gives the
 > correct printf error messages on non-existant file or wrong head in file.
 > However, size(1), nm(1) and /usr/lib/c0 all crash when given correct arguments.

 > Of course it's difficult to debug. There could be errors in:

 > 	- the emulated API (2nd Ed API != 1st Ed API)
 > 	- the environment provided to the emulated program
 > 	- simulation of the instructions (PDP-11/20 different to later versions)

 > or a combination of all three :-)

Well, there is the 405-407 issue, although if a program
is able to write an error message it at least got into
execution.

I think that all 11/20 instructions work on later processors.
However: does the simulator handle the 11/20 EAE device?
It would be used on any */% operation or shifts of more than
one place.  Look for unhandled accesses to locations
177300 and just above.

---

From: Warren Toomey <wkt>
Date: Mon, 10 Jan 2000 13:17:09 +1100 (EST)

Dennis,
	Just a quick note. Using s2-bits C compiler, I have recompiled
both c0 and c1 from last1120c. Then by moving the new c0 and c1 into
/usr/lib, I have recompiled c0 and c1 with themselves.

Currently at home, expecting a phone call, so must disconnect
the modem. More details later.

	Warren